Jump to content


Photo

Mac OS 10.6 Citrix Online Plug-in does not work- "class com.citrix.ConnectionCenter not found"

Started by Dylan White , 02 March 2011 - 08:34 PM
2 replies to this topic

Dylan White Members

Dylan White
  • 1 posts

Posted 02 March 2011 - 08:34 PM

Hello,

I've tried my best but now I'm stumped. Brand new Macbook Air, newest Snow Leopard (10.6.6), newest Java for Mac OS (1.6.0_22), newest Citrix client for Mac (11.2). I've tried Safari (32 and 64 bit) and Firefox, put Java into 32 bit, and loaded and reloaded the plug-in more times than I want to remember. But I cannot use the Web access to the Citrix server. (I only need Web access.)

It all boils down to this. I can log in to my company's Citrix site (https://sbcint...) without problem. I can see the app I need - Desktop. But when I click it, I presume it starts a Java app to download the ICA file - but this fails and I never get to the ICA file. The full Java console report is copied below, saying that the class com.citrix.ConnectionCenter could not be found.

This is a Citrix class, not a Java native class. Apple support have been extraordinarily helpful, but at this point they said that it's a Citrix issue, not a Mac issue, they can do no more.

Anyone - is there yet something else I could try? Many thanks for any sugggestions!

Dylan

Java Console Log:

Java Plug-in 1.6.0_22
Using JRE version 1.6.0_22-b04-307-10M3261 Java HotSpot™ 64-Bit Server VM
User home directory = /Users/dylanw
...
load: class com.citrix.ConnectionCenter not found.
java.lang.ClassNotFoundException: com.citrix.ConnectionCenter
at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:211)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:144)
at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:662)
at sun.applet.AppletPanel.createApplet(AppletPanel.java:785)
at sun.plugin.AppletViewer.createApplet(AppletViewer.java:2354)
at sun.applet.AppletPanel.runLoader(AppletPanel.java:714)
at sun.applet.AppletPanel.run(AppletPanel.java:368)
at java.lang.Thread.run(Thread.java:680)



Laurent Helbert Members

Laurent Helbert
  • 1 posts

Posted 13 June 2011 - 10:58 PM

I have exactly the same issue except that I have this on an IMAC intel, same MAC OS level. I did all the same clean and reinstall operations a number of times, I have tried Safari, Firefox and Chrome with no success.
I have the exact same error message.
The client works perfectly if I boot on Vista so all the hardware and Internet connectivity is fine.
One of my colleagues got it to work on his MacBook Air with the same OS version, however applying what he did on his side did solve the issue for me (it was basically cleaning everything and installing last version of every item, from Java to the browser including the Citrix client).

So there must be a solution somewhere but I admit that I have also run out of ideas.

Isn't there any one from the Citrix team that can help ? This does not seem to be the only occurrence of such an issue, surely you should be able to help with this.

Thanks in advance for any new idea.



manesh sonah Members

manesh sonah
  • 2 posts

Posted 26 September 2011 - 02:52 AM

Hi, if anyone is having the same problem I will advice to upgrade to the 11.2 online plug-in. If you're having trouble installing the plugin, I found a clean tutorial here:
http://www.maurisource.com/blog/how-to-copy-paste-from-citrix-to-my-mac/

Edited by: maurisource on Sep 25, 2011 10:52 PM