Jump to content


Photo

Anyone seeing exception code c0000135 with the 12.0.0 or 12.0.3 client?

Started by Jason D Knight , 07 October 2010 - 09:15 PM
12 replies to this topic

Jason D Knight Citrix Employees

Jason D Knight
  • 235 posts

Posted 07 October 2010 - 09:15 PM

Hello. We've seen some problems reported in the 12.0.0 and 12.0.3 clients with exception code c0000135, which means DLL not found. Usually the DLL that can't be found is cst.dll, but we've seen others too. It looks like this happens only on Vista, not XP or Windows 7.

We're able to reproduce the crash, but only if we rename or delete cst.dll manually, and we doubt users are doing that. If you're experiencing this problem, please contact me so I can get more information and, I hope, determine the root cause of this problem. Thank you.

- Jason Knight, Software Development Engineer



Rudy Bauer Members

Rudy Bauer
  • 37 posts

Posted 11 October 2010 - 08:12 PM

We are currently seeing the missing CST.dll problem on some of our Windows 7 builds. Is there a know resolution?

Thanks,
Rudy

Attached Files



Jason D Knight Citrix Employees

Jason D Knight
  • 235 posts

Posted 11 October 2010 - 09:52 PM

Hi, Rudy. At this time there is no known resolution, because the root cause is not known. We have not seen this issue in house yet.

I'll contact you directly to get more information. If this information helps me reproduce the problem, obviously that will make it easier to find the solution.



Rudy Bauer Members

Rudy Bauer
  • 37 posts

Posted 11 October 2010 - 10:21 PM

Thanks. We tried replacing the dll only and that did not work. Neither did the reinstall from SCCM. A manual re-install fixed the issue. This is the 12.0.3 client.



Jason D Knight Citrix Employees

Jason D Knight
  • 235 posts

Posted 12 October 2010 - 02:09 AM

Good to hear. Had the client been deployed through SCCM when you encountered this problem?



Rudy Bauer Members

Rudy Bauer
  • 37 posts

Posted 12 October 2010 - 04:06 PM

Yes, we are deploying through SCCM using the full client with commandline switch to install web client with SSON.

CitrixOnlinePluginFull.exe ADDLOCAL="ICA_Client,SSON"



Jeph Yang Members

Jeph Yang
  • 1 posts

Posted 09 November 2010 - 04:24 AM

Hi Jason,

We've noticed the problem on a number of our customers' home PCs on Windows 7. However, they're unable to recall exactly how the issue was created and we don't have a precise way to trace it, being as these are personal computers at home. From what we've observed, when the issue occurs the customers will have both 12.x installed as well as an older version, such as 11.2. I'm not sure how this happens, but I believe the customers are installing 11.2 on top of 12.0.0 or 12.0.3. Our admin has the 11.2 client advertised on the login page (I've inquired about removing it), so it's likely the customers are installing the older version on top of the newer version, in some cases many times over.

We've managed to get a few of our customers working by uninstalling both versions, assuming they don't encounter fatal errors or other uninstaller errors. Once uninstalled, we have them reinstall the older version (11.2) and they can get by on the older client. The remaining majority aren't so lucky, as they now have uninstaller errors and cannot remove either version of the software short of performing a manual uninstall.

Any additional insight you might have would be greatly appreciated.

Thanks.

OR Service Desk



Dave H Members

Dave H
  • 1 posts

Posted 09 January 2011 - 08:09 PM

I had this same problem and your information helped me quite a bit. I checked and had the 12.0.0 version and 11.2 versions installed, and when I attempted to uninstall the 12.0 version I encountered a "fatal error" and was unable to reinstall 11.2 and log in.
What I did then was find a program that would force the uninstall, and this worked. I was unable to proceed to reinstall the 11.2 version and I am now able to log in. The program I used to force the uninstall was the free version of Fix Helpmate which has an uninstall manager component. I'm sure that there are many free programs out there that may be more or less capable, and I cannot speak for the overall quality of the one I used other than to say that the uninstall feature worked.
To summarize, finding a way to uninstall the program even though my computer's add/remove feature was not working fixed the problem for me. Thanks.



Melanie Tangie Members

Melanie Tangie
  • 1 posts

Posted 21 January 2011 - 05:23 PM

I have this problem (cst.dll is missing) on my home laptop. I am now getting the uninstaller error saying something didnt go as expected and i am unable to remove it. Has there been any fix discovered for this?



Travis Stiegler Members
  • #10

Travis Stiegler
  • 1 posts

Posted 17 February 2011 - 06:12 AM

I am trying to open an remote access in Citrix and when I try I get: windows title bar - wfcrun32.exe System Error, message - 'CST.dll is missing'. And I am using Windows 7 on my laptop.
Hopefully someone figures this out. Thanks.

Edited by: travisstiegler on Feb 17, 2011 1:13 AM

Attached Files



Josh Schneider Members
  • #11

Josh Schneider
  • 1 posts

Posted 07 May 2011 - 12:21 AM

is there any solution to this yet?



tracy halsey Members
  • #12

tracy halsey
  • 1 posts

Posted 12 July 2011 - 11:48 PM

Just had this problem, where now my citrix will not load. I try to run just the citrix software, and i get the error saying that i am missing CST.DLL and to reinstall it.

Yesterday i uploaded a few pictures to facebook for the first time from this computer. Before this my citrix worked just fine, and now i am getting the error message. Would love to know how to fix this.



Kenneth Snyder Members
  • #13

Kenneth Snyder
  • 5 posts

Posted 13 July 2011 - 06:18 PM

where can we get the cst.dll file?

I just installed v11.2 and then upgraded to v12.1 on a brand new laptop.

I had version 11.2 and upgraded to 12.1 and am using IE 9
I am unable to use citrix now
I get 2 errors:
unable to find cst.dll
cannnot read internetsettings windows registry key

I am also unable to uninstall either version.

I am stuck.



Give Us feedback