Jump to content


Photo

Netscaler platinum edition

Started by Henrik Christensen , 20 April 2010 - 10:39 AM
4 replies to this topic

Best Answer Christoph Wegener , 20 April 2010 - 10:42 AM

Hi Henrik,

You allocated the platform licenses to the wrong hostname:

10:03:40 (CITRIX) Wrong hostid on SERVER line for license file:
10:03:40 (CITRIX) /nsconfig/license/netsdkba001_AGPlatform.lic
10:03:40 (CITRIX) SERVER line says HOSTNAME=003048f853bd, hostid is HOSTNAME=netsdkba000
10:03:40 (CITRIX) Invalid hostid on SERVER line
10:03:40 (CITRIX) Disabling 10000 licenses from feature CAG_ICA_CCU(08E1 E74C 17D2 1EDC )

Henrik Christensen Members

Henrik Christensen
  • 264 posts

Posted 20 April 2010 - 10:39 AM

I tried to put the new CAG platform license on one of our boxes with 9.2 firmware

The license log now reports: Users of CAG_ICA_CCU: (Error: 10000 licenses, unsupported by licensed server)

Is that expected or did the 9.2 firmware not get an license server update to support the new platform license?
I only uploaded the license file to the box running as secondary, so I haven't tried running in production yet.

Br Henrik

Attached Files



Christoph Wegener Members

Christoph Wegener
  • 2,622 posts

Posted 20 April 2010 - 10:42 AM

Hi Henrik,

You allocated the platform licenses to the wrong hostname:

10:03:40 (CITRIX) Wrong hostid on SERVER line for license file:
10:03:40 (CITRIX) /nsconfig/license/netsdkba001_AGPlatform.lic
10:03:40 (CITRIX) SERVER line says HOSTNAME=003048f853bd, hostid is HOSTNAME=netsdkba000
10:03:40 (CITRIX) Invalid hostid on SERVER line
10:03:40 (CITRIX) Disabling 10000 licenses from feature CAG_ICA_CCU(08E1 E74C 17D2 1EDC )


Best Answer

Henrik Christensen Members

Henrik Christensen
  • 264 posts

Posted 20 April 2010 - 11:09 AM

Yes, that is correct. Thanks!

I got confused on what to use on which license. I cant seem to find the correct documentation from citrix on this. And on mycitrix, it would not register my hostname on the first attempts made. But today it worked.

Henrik



Gregor Visconty Citrix Employees

Gregor Visconty
  • 90 posts

Posted 20 April 2010 - 05:54 PM

Have you seen this?

http://support.citrix.com/article/ctx122426



Henrik Christensen Members

Henrik Christensen
  • 264 posts

Posted 21 April 2010 - 10:55 AM

No I havent seen that before. It applies to VPX, and in this case im running on mpx 5500.
The guide is also not updated for 9.2 firmware I guess, as the mac hostname is not used anymore. If I activate an license for netscaler, it removes the hostname entry in mycitrix. The resulting hostname when viewed in the license file is "ANY". This might or might not apply to VPX - again this is very unclear reading the various documents from Citrix.

I can find many license guides on licensing netscaler and cag, and this is very confusing to me as it all depends on hardware, firmware, edition etc.

To sum up on what I had to do to get a mpx 5500 platinum HA pair working with correct licensing:

Activate platinum license using NO hostname for licenseserver - mycitrix hides the hostname box when filtering on this type of license.
Activate new CAG platform license (supported by 9.2x firmware) using the hostname of the appliance
Activate additional CCU Universal CAG licenses using the hostname of the appliance
Configure max AAA users to the amount of CAG uni licenses (a bit stupid to have to do this, but that's my opinion)

BR Henrik