Jump to content


Photo

iSCSI could not get an IP address

Started by Dalan Campbell , 01 September 2009 - 08:17 PM
21 replies to this topic

Best Answer Brian Ehlert , 01 September 2009 - 08:35 PM

Lets begin with the easier issue.

First of all, there is a requirement that a DHCP server is available on the network where you will be running your conversions.

If that requirement is met please try the folowing:

In XenCenter, select View, and turn on "Hidden Objects"

Under your Pool Master (where you installed the XenServer-CIM component) you should see a grey VM template named "iSCSI Target"

Select this Template, then select its Network Tab.
(I am suspecting that you will not see an interface.)

Click "Add Interface" and select the Network that will connect you to the same subnet where you are running the Citrix OVF Tool, then Finish.
(You should now see a network interface defined for this template)

Return to View and turn off "Hidden Objects"

Now, you should be able to perform an Import or Export.

Please report your experiences and any additional host configuration so we can continue to improve the product.

Dalan Campbell Members

Dalan Campbell
  • 12 posts

Posted 01 September 2009 - 08:17 PM

my first attempt at using Project Kensho (v1.3 with XenServer 5.5 - two servers in pool). I think I have installed correctly but durring export attempt I received error "iSCSI could not get an IP address". My goal is to migrate some VMs from Hyper-V to XS, it looked like Kensho might be a good tool to try. Is there any documentation regarding errors? Thanks for the help.



Brian Ehlert Citrix Employees

Brian Ehlert
  • 352 posts

Posted 01 September 2009 - 08:35 PM

Lets begin with the easier issue.

First of all, there is a requirement that a DHCP server is available on the network where you will be running your conversions.

If that requirement is met please try the folowing:

In XenCenter, select View, and turn on "Hidden Objects"

Under your Pool Master (where you installed the XenServer-CIM component) you should see a grey VM template named "iSCSI Target"

Select this Template, then select its Network Tab.
(I am suspecting that you will not see an interface.)

Click "Add Interface" and select the Network that will connect you to the same subnet where you are running the Citrix OVF Tool, then Finish.
(You should now see a network interface defined for this template)

Return to View and turn off "Hidden Objects"

Now, you should be able to perform an Import or Export.

Please report your experiences and any additional host configuration so we can continue to improve the product.


Best Answer

Dalan Campbell Members

Dalan Campbell
  • 12 posts

Posted 01 September 2009 - 10:53 PM

That has worked perfectly - thanks



Brian Ehlert Citrix Employees

Brian Ehlert
  • 352 posts

Posted 02 September 2009 - 02:30 PM

I am guessing that your situation was the second case.

If you could provide me some background information about your installation, it would be very helpful in assiting us in understand the root cause of the issue you ran into.

You may post here, or email me directly at: brian dot ehlert at citrix dot com

What I am curious about is:
Is this a clean install of XenServer 5.5 or was it upgraded for 5.0 or earlier?
What is your networking configuration?
Any other details that you might be willing to share.

Thank you!



Dalan Campbell Members

Dalan Campbell
  • 12 posts

Posted 02 September 2009 - 06:30 PM

Brian --

This is a clean install of XenServer 5.5. The OVFlibrary share is in the same subnet as the XenServers but my Kensho OVF tool is in a separate subnet. I started with an export from XenServer, deleted the VM, and reimport the VM from the OVFlibrary - with your help, this has all worked. I am now trying to add access to a Hyper-V host and I get errors there - 1. <IP address> failed, 2. Map Utility.AddVMs Failed, 3. Process VMList Commands failed, 4. Cannot identify server <IP address> type. Any direction you can give me? - The Hyper-V server is in the same subnet as the XenServers, I am using its local Administrator to logon, have tried both secure and un-secure entries in the sever setup screen. I've missed something somewhere - very much appreciate your help.

-- Dalan



Brian Ehlert Citrix Employees

Brian Ehlert
  • 352 posts

Posted 02 September 2009 - 07:19 PM

With Hyper-V there are a few issues.

1) the port for WinRM
2) only unsecured communication is supported unless you generate and install certificates.
3) Remote Managemet must be enabled in the firewall rules.
4) I am assuming that you performed the instalaltion steps outlined in the administration guides.

I have put this video together to cover the basic gotchas of Hyper-V:
http://www.citrix.com/tv/#video/971

From reading your description I am guessing that the Remote Management firewall rule has not been enabled.


Helpful Answer

Dalan Campbell Members

Dalan Campbell
  • 12 posts

Posted 02 September 2009 - 10:22 PM

Thank you Brian, it was the winrm config stuff which I forgot. I was able to create my Hyper-V server, but my attempt to export a HV-VM fails. How can I clear the log so I can send a "clean" error?



Brian Ehlert Citrix Employees

Brian Ehlert
  • 352 posts

Posted 02 September 2009 - 10:28 PM

The logs for the OVF Tool are unique for each session.

If you close the OVF Tool and then launch it again - it will begin a new log and verify communication to each server, and validate any OVF's in the Library.

The logs can be found under %appdata%\Citrix\Kensho

There is also a Clear Log History option, but that does not restart the log for the current session, only the previous sessions.


Helpful Answer

Dalan Campbell Members

Dalan Campbell
  • 12 posts

Posted 03 September 2009 - 02:43 AM

Here are the log entries (names/address modified) for my error:

Audit:2009.9.2.20.30.20,632:[JUGS\gopher] Get-VMList(Server=192.168.11.41)
Audit:2009.9.2.20.30.22,804:[JUGS\gopher] Get-VMList(Server=192.168.11.3)
Audit:2009.9.2.20.31.26,351:[JUGS\gopher] Export:OVF: WEBsrv02 VMs[1] WEBsrv02
Audit:2009.9.2.20.31.26,398:[JUGS\gopher] Export(ovfName=WEBsrv02, vmName=WEBsrv02, vmUuid=B3F3208A-F05C-4FC7-B111-BB3833C85AB5, Path=\\192.168.11.16\OVFlibrary\WEBsrv02)
Audit:2009.9.2.20.31.26,476:[JUGS\gopher] Get-VMList(Server=192.168.11.41)
Audit:2009.9.2.20.31.26,789:[JUGS\gopher] Get-VMList(Server=192.168.11.3)
Error:2009.9.2.20.31.27,70: OnUpdateEvent State: [Exception] Message: [FAILED: Unable to cast COM object of type 'Interop.WSManAutomation.WSManClass' to interface type 'Interop.WSManAutomation.IWSManEx2'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{1D1B5AE0-42D9-4021-8261-3987619512E9}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).]
Error:2009.9.2.20.31.27,117: Finalize Envelope FAILED, no Virtual Systems Defined.
Error:2009.9.2.20.31.27,132: File handling error. The UNC path should be of the form \\server\share.
Error:2009.9.2.20.31.29,164: Export Error: Cannot find file: \\192.168.11.16\OVFlibrary\WEBsrv02\WEBsrv02.ovf
Audit:2009.9.2.20.31.29,242:[JUGS\gopher] Get-VMList(Server=192.168.11.41)
Audit:2009.9.2.20.31.29,601:[JUGS\gopher] Get-VMList(Server=192.168.11.3)

somethings missing here - let me try attachment

Edited by: Dalan Campbell on Sep 2, 2009 10:47 PM

Attached Files



Brian Ehlert Citrix Employees
  • #10

Brian Ehlert
  • 352 posts

Posted 03 September 2009 - 02:34 PM

Okay, the details are a great help.

I have a couple questions:
What is the operating system of the machine where you are running the OVF Tool?
Did you install, then uninstall, then reinstall the OVF Tool?

Here is the workaround from the ReadMe that I believe will resolve the issue:

Following the application of SP2 to Vista and Server 2008 or the uninstall of Kensho OVF Tool, the Kensho OVF Tool fails during export or import of an appliance with Hyper-V with the error: FAILED: Unable to cast COM object of type 'Interop.WSManAutomation.WSManClass' to interface type 'Interop.WSManAutomation.IWSManEx2’.

To resolve, do the following:

Open a command prompt and enter:

cd c:\windows\system32
regsvr32 wsmauto.dll



Dalan Campbell Members
  • #11

Dalan Campbell
  • 12 posts

Posted 03 September 2009 - 07:48 PM

The OVF Tool in installed on my laptop on Windows XP sp3. I don't remember for sure if I installed it more that once - I may have. Reading in the Admin Guide under Prerequsites, I see WinRM is supposed to be on OVF Tool workstation (which I do have installed), but I don't think I did any WinRM configuration on that system. I ran the regsvr32 command you recommend and my export from Hyper-V is now running - thanks.



Brian Ehlert Citrix Employees
  • #12

Brian Ehlert
  • 352 posts

Posted 03 September 2009 - 08:11 PM

The WinRM settings are modified on the client where OVF Tool is installed during the installation. You should not need to modify them.

The settings on any Hyper-V hosts must be modified manually.

Glad things are working for you now.



Carlos Aya Members
  • #13

Carlos Aya
  • 3 posts

Posted 24 November 2009 - 04:53 PM

We are being forced to move from Xen to Hyper-V, so the fact that this tool is freely available is a godsend.

I just wanted to drop in and say that this thread was very helpful for me in getting Kensho up and running. I ran into every single issue that was discussed here -- including the dll that needed to be registered, which was even needed on a first-time install of the tools in my case.

One comment I would like to make is on the DHCP requirement. I do not typically enable DHCP on my production server subnets, so the fact that this was necessary was a bit disappointing for me. Is there any way around this requirement?

Either way, thanks for the tremendous help!



Brian Ehlert Citrix Employees
  • #14

Brian Ehlert
  • 352 posts

Posted 24 November 2009 - 05:15 PM

I am sorry to say that there is no way around the DHCP requirement with this release.

Thank you for your input and the contribution of your use case.



Nick Freeman Members
  • #15

Nick Freeman
  • 1 posts

Posted 09 June 2010 - 09:40 PM

Wondering if you could help with the following?

Just installed Kensho 1.3 and trying to export VMs from a Xen5.5.0 EPT update 2 server, but I get the “iSCSI could not get an IP address” error message.

I followed the advice within this thread, such as going into View Hidden objects and checking the network tab of the iSCSI target (hidden) template etc, but to no avail.

I have a DHCP server, which is running an a VM on the XenServer in question. Is that an issue here?

Any suggestions you can provide on where to go from here?



Brian Ehlert Citrix Employees
  • #16

Brian Ehlert
  • 352 posts

Posted 09 June 2010 - 09:45 PM

I have seen cases where the DHCP (or DNS, or AD, et. al.) services running in a VM on the same host causes a problem.

So, yes - it could be an issue.

The only way to know is to target another host, or to watch the console of the iSCSI VM as it boots.

On a realted note: If you update to XenServer 5.6 this same Kensho functionality is now native (both XenCenter and XenServer must be at 5.6).



Matthew Mueller Members
  • #17

Matthew Mueller
  • 8 posts

Posted 29 June 2010 - 01:57 PM

Hi, I'm hoping someone can help me here. This Kensho tool is sweet!...if i can only get it to work on my pc.

I've run through these steps on my Hyper-V server, which is 6.1.7600.16385, 2008 R2 RTM i believe.

winrm quickconfig (said yes to enable firewall)
winrm p winrm/config/service @{AllowUnencrypted="true"}
winrm set winrm/config/service/auth @{Basic="true"}
netsh advfirewall firewall set rule group="remote administration" new enable=yes

All went through without an error (seemingly).

Moving on to my client.... I was able to add an OVF file via the library feature, but when i try to add my hyper-v server, using local administrator account (which i triple checked), port 5985 (which i think is correct for R2?) unencrypted (per the video), i get

1 192.168.xxx.xxx failed
2 Map utility .AddVMs Failed
3 Process VMList COmmands failed
4 Cannot identify server 192.168.xxx.xxx type.

Can someone point me in the right direction? I'd like to import a VMWare VM to a Hyper-V server

One addition: the Kensho log is showing this error:

wsManIdentify: Inner Error: The WinRM client cannot process the request. Unencrypted traffic is currently disabled in the client configuration. Change the client configuration and try the request again.

Is there also a client side unencrypted setting i need to make somewhere (I am on windows 7)? I tried this, but it would not take:
winrm p winrm/config/client @{AllowUnencrypted="true"}

WHen i set this on the hyper-v server with winrm/config/serivce, the setting did take without error

Edited by: Matthew Mueller on Jun 29, 2010 1:55 PM



Brian Ehlert Citrix Employees
  • #18

Brian Ehlert
  • 352 posts

Posted 29 June 2010 - 03:07 PM

This command here:
winrm set winrm/config/service/auth @{Basic="true"}
should also be a "put"

Don't forget: On your client you need to tweak the WinRM settings as well. Especially if you are runnign Win7 or Vista and did not do a run as when you ran the installer (it quietly tries and fails to tweak the winrm settings).

If you could add some log detail, that would be great - it tells us much more.

%appdata%/Citrix/Kensho

There is also an administration guide that is on your client machine in: ProgramFiles\Citrix\Kensho

One other interesting behavior is that you must use the local administrator account of the Hyper-V Server, and if you logon to your client machine as the local administrator as well - the passwords must match (it is windows trying to use the local account, instead of the provided credentials).



Matthew Mueller Members
  • #19

Matthew Mueller
  • 8 posts

Posted 29 June 2010 - 06:00 PM

Brian, i'm not sure if we posted at the exact same time, and also not sure if it will tell you i updated my last post, so i'll repost the end:

One addition: the Kensho log is showing this error:

wsManIdentify: Inner Error: The WinRM client cannot process the request. Unencrypted traffic is currently disabled in the client configuration. Change the client configuration and try the request again.

Is there also a client side unencrypted setting i need to make somewhere (I am on windows 7)? I tried this, but it would not take:
winrm p winrm/config/client @{AllowUnencrypted="true"}

WHen i set this on the hyper-v server with winrm/config/serivce, the setting did take without error

Also, i did not understand your "put" statement - could you please clarify?



Brian Ehlert Citrix Employees
  • #20

Brian Ehlert
  • 352 posts

Posted 29 June 2010 - 06:07 PM

Yes, there are both client and server side settings.

The client side settings can only be done in an elevated command prompt.
(that is the basis for my statement about running the installer using elevated priveledges and not user priveledges).

You must open your command prompt with "run as: administrator" to be allowed to change the settings - or logon locally as the local administrator.

At you Hyper-V host, most likely you were logged on as the local administrator, therefore no hitch.

Within your elevated command prompt (at the client):
winrm quickconfig
winrm p winrm/config/client @{AllowUnencrypted=”true”}
winrm p winrm/config/client/auth @{Basic=”true”}