Jump to content


Photo

Cannot connect to Citrix Server from XenApp

Started by Craig MacNeil , 02 March 2009 - 05:22 PM
4 replies to this topic

Craig MacNeil Members

Craig MacNeil
  • 4 posts

Posted 02 March 2009 - 05:22 PM

Hi everyone,
I have installed Citrix Presentation Server 4.5 on a Windows 2003 Server. I am trying to connect to it using XenApp client. I am trying to connect to the citrix server using the following format: https://citrix

I get the following error message: "The server has an invalid root certificate, so this may be a malicious server. Connection dropped." Once I press OK I get "Citrix XenApp could not connect to the server. Please check your network connectivity."

I can ping the computer and get a response, so I don't think it is network problems.

I have also tried connecting to the server by just typing in the server name: citrix

I get the following error message: "Citrix XenApp could not contact the server entered. This may be because the server is down, there is an error in the configuration file from the server, or the details are incorrect. Please try again."

Does anyone have any suggestions on how to troubleshoot this? I am new to Citrix so any help at all would be much appreciated.

Thanks,



Peter David Members

Peter David
  • 5,733 posts

Posted 02 March 2009 - 11:55 PM

How are you trying to connect? Web Interface, the full PN client, PN Agent?

XenApp doesn't listen directly on 443 by default without the configuration of SSLRelay, do you really need to secure the connection? Most shops are happy to connect using the default ICA port of 1494.



- Arbil - Members

- Arbil -
  • 619 posts

Posted 03 March 2009 - 01:14 AM

Hi

can you give us some details on your setup specially the web interface part?
and have you tried to access publish apps via program neighborhood?

hope it helps

-Arbil-



Craig MacNeil Members

Craig MacNeil
  • 4 posts

Posted 03 March 2009 - 07:18 PM

Thanks for the feedback guys.

I am trying to connect through the web interface. Originally, I was having problems even getting the web interface going. These seem to be sorted out as I can now connect through the web. This still doesn't explain to me what is going on with the XenApp. I assume the XenApp is a different interface to connect with the Citrix box. I would think that if I can connect with the Web Application that XenApp would work as well.

One thing that is annoying is that whenever I go into the web interface and double click an application to launch, I get an error saying: "Cannot connect to the Citrix XenApp server. The Citrix XenApp server you have selected is not accepting connections". Once I close this error, and double click again, the application will launch for me. Any idea as to why I get this error the first time but not the second.

Thanks again



KEN ZYGMUNT Members

KEN ZYGMUNT
  • 1,295 posts

Posted 04 March 2009 - 12:49 AM

Craig

firstly, from what you've previously said, you're doing all this testing on the same network segment (client PC and Citrix Server).

Secondly, can you go into the Web Interface (Access) Management Console, and click on the "Manage Server Farms".
Is there only one farm there?
If you edit the farm, are all the Citrix Servers listed there valid servers? are using using IP address(es) or fully qualified domain names?
If there's more than one, try removing the tick in the 'use the server list for load balancing'
The XML Port specified,

finally, try right clicking on the published app in web interface, and selecting "Save Target As", and save the launch.ica file to your desktop. Open it in notepad and see if the servers listed there are correct.

XenApp is the client that needs to be installed on your local PC. Web Interface is the method of authentication onto the Citrix farm and displaying the list of published applications you have access to. Once you click on a published app, a file called launch.ica gets copied down to your PC and automatically gets passed to the XenApp client. this file tells the client how to connect to the Citrix Servers. The fact that the first time you get an error means that the contents of this file contains invalid information for connecting to the Citrix Server(s).

Regards

Ken Z



Give Us feedback